9
8

MongoDB (Fixed)

klopp
2015-09-08 13:55 обн. 2015-09-08 16:53

Очередной сеанс тупизма.

Свежевставшая монга с зависимостями (в том же perlbrew, конечно же), use MongoDB:

You can only consume roles, Throwable is not a Moose role at /opt/perlbrew/perls/perl-5.22.0/lib/site_perl/5.22.0/x86_64-linux/Moose/Exporter.pm line 419

?

P.S. Я тупое креведко! Дело в том, что Moo, который был установлен из-под perlbrew (perl 5.22), не ставил свой Moo::Role (подхватывал хостовый Moo::Role, что ли? Там perl 5.18, и, соответственно, более древние модули из дебиановских реп). Ручная установка Moo::Role из-под perlbrew помогла. Везде бардак :)

Чтобы ответить, залогиньтесь или зарегистрируйтесь.
  • @user
  • _italic_

    italic

  • **bold**

    bold

  • [PP](http://pragmaticperl.com)

    PP

  • <http://pragmaticperl.com>

    http://pragmaticperl.com

  • module:Plack

    Plack

  • release:URI

    URI

  • author:VTI

    VTI

  • `my $foo = 'bar'`
  • ```
    my $multi;
    $line;
    ```